Comparing Common Layer 2 Configurations to Arista and Cisco

Follow

The configuration of layer 2 networking in Cumulus Linux (or any Linux distribution for that matter) is different from the incumbent network operating systems like Cisco's NX-OS or Arista's EOS. This article details some of the syntax differences using common layer 2 examples.

{{table_of_contents}}

Configuring Trunks

Configuring trunks with two VLANs on ports 1 and 2:

Cumulus Linux Cisco NX-OS Arista EOS
auto bridge
iface bridge
  bridge-vlan-aware yes
  bridge-ports glob swp1-2
  bridge-vids 100 200
    
vlan 100,200

interface ethernet 1/1
    switchport mode trunk

interface ethernet 1/2
    switchport mode trunk  

!
vlan 100,200 !
interface Ethernet1 switchport mode trunk !
interface Ethernet2 switchport mode trunk

Pruning a Trunk

Pruning VLAN 100 from the trunk on port 1:

Cumulus Linux Cisco NX-OS Arista EOS
auto bridge
iface bridge
  bridge-vlan-aware yes
  bridge-ports glob swp1-2
  bridge-vids 100 200
auto swp1 iface swp1 bridge-vids 200
vlan 100,200

interface ethernet 1/1
    switchport mode trunk
    switchport trunk allowed vlan 200

interface ethernet 1/2
    switchport mode trunk
!
vlan 100,200 !
interface Ethernet1 switchport mode trunk !
interface Ethernet2 switchport mode trunk switchport trunk allowed vlan 200

Configuring Access Ports

Configuring two VLANs in access mode: port 1 VLAN 100 and port 2 VLAN 200:

Cumulus Linux Cisco NX-OS Arista EOS
auto bridge
iface bridge
  bridge-vlan-aware yes
  bridge-ports glob swp1-2
  bridge-vids 100 200
auto swp1 iface swp1 bridge-access 100
auto swp2 iface swp2 bridge-access 200
vlan 100,200

interface ethernet 1/1
    switchport mode access
    switchport access vlan 100

interface ethernet 1/2
    switchport mode access
    switchport access vlan 200

!
vlan 100,200 !
interface Ethernet1 switchport access vlan 100 !
interface Ethernet2 switchport access vlan 200

Changing the Native (Untagged) VLAN for a Single Trunk

Setting the native VLAN to 100 on port 1 and 200 on port 2 when both ports are trunks allowing VLAN 1-200:

Cumulus Linux Cisco NX-OS Arista EOS
auto bridge
iface bridge
  bridge-vlan-aware yes
  bridge-ports glob swp1-2
bridge-vids 1-200
auto swp1
iface swp1
  bridge-pvid 100
auto swp2 iface swp2 bridge-pvid 200
vlan 1-200

interface ethernet 1/1-2
    switchport mode trunk
    switchport trunk allowed vlan 1-200

interface ethernet 1/1
    switchport trunk native vlan 100

interface ethernet 1/2
    switchport trunk native vlan 200

!
vlan 1-200 !
interface Ethernet1 switchport mode trunk switchport trunk native vlan 100 !
interface Ethernet2
switchport mode trunk switchport trunk native vlan 200

See Also

Have more questions? Submit a request

Comments

This support portal has moved

Cumulus Networks is now part of the NVIDIA Networking Business Unit! The NVIDIA Cumulus Global Support Services (GSS) team has merged its operations with the NVIDIA Mellanox support services team.

You can access NVIDIA Cumulus support content from the Mellanox support portal.

You open and update new cases on the Mellanox support portal. Any previous cases that have been closed have been migrated to the Mellanox support portal.

Cases that are still open on the Cumulus portal will continue to be managed on the Cumulus portal. Once these cases close, they will be moved to the Mellanox support portal.

Powered by Zendesk