This knowledge base has moved to the documentation site. Please visit the knowledge base here for the most up to date content. This site is no longer maintained.

Interface IP Address Is Reachable on an Interface that Is Down

Follow

Issue

The IP address associated with an interface that is administratively up but physically down is reachable through other interfaces from external sources.

Environment

  • Cumulus Linux 1.5.x and higher

Cause

In contrast to the strong host model used by some other routing devices, Linux uses the weak host model and considers the IP address as a property of the device rather than the interface it is defined on. This was historically due to preferring that if the device was reachable via any interface, the connection should be allowed. Note that this is expected Linux behavior is not unique to Cumulus Linux.

Information on the weak host vs strong host models is available from many sources, including RFC-6419. Information on Linux interface operational states is available here.

While this behavior may seem unusual to a network administrator, it is not unexpected and should not create problems for normal operation.

Resolution

If an interface is manually set down, you won't see the above behavior. To remove the local interface address from operation, set the link down using one of the following commands:

sudo ip link set swpXX down
sudo ifdown swpXX

(where XX is the number of the swp interface)

 

Comments

This support portal has moved

Cumulus Networks is now part of the NVIDIA Networking Business Unit! The NVIDIA Cumulus Global Support Services (GSS) team has merged its operations with the NVIDIA Mellanox support services team.

You can access NVIDIA Cumulus support content from the Mellanox support portal.

You open and update new cases on the Mellanox support portal. Any previous cases that have been closed have been migrated to the Mellanox support portal.

Cases that are still open on the Cumulus portal will continue to be managed on the Cumulus portal. Once these cases close, they will be moved to the Mellanox support portal.

Powered by Zendesk